Slowness in US East region
Incident Report for Actionstep
Resolved
This incident has now been resolved and normal service has resumed. Thank you for your patience and we apologize for any inconvenience caused.
Posted Nov 19, 2020 - 04:54 NZDT
Investigating
We are currently investigating this issue.
Posted Nov 19, 2020 - 04:04 NZDT
This incident affected: USA (East).