Calendar Accessibility
Incident Report for Actionstep
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 16:34 NZDT
Investigating
We are currently investigating a known issue in relation to users not being able to access their calendars.
Posted Jan 22, 2021 - 11:58 NZDT
This incident affected: USA (West), USA (East), United Kingdom, Middle East, Africa, and Europe, and New Zealand, Australia, and South Pacific.