Reported outage with Microsoft 365 servers

Incident Report for Actionstep

Resolved

It looks like Microsoft has everything under control. If you're still experiencing issues with Outlook calendars, emails, or the add-in, please let us know!
Posted 2 years ago. Jun 08, 2023 - 04:03 NZST

Update

Microsoft 365 users are still reporting issues (https://twitter.com/msft365status?lang=en) and we are continuing to monitor.
Posted 2 years ago. Jun 07, 2023 - 04:01 NZST

Identified

Microsoft has reported an outage with Microsoft 365 servers. This outage may affect emails and calendars.
Status updates for this outage with Microsoft can be found here
https://twitter.com/MSFT365Status
Posted 2 years ago. Jun 06, 2023 - 08:33 NZST