Service Interruption – AWS Outage Impacting Support Systems - 20 October 2025

Incident Report for Actionstep Practice Management

Postmortem

Post-Incident Summary: Global – Third-Party Communication Outage – October 20, 2025

Incident Overview
On October 20, 2025, a widespread AWS outage in the US-East-1 region affected several third-party platforms, including Freshdesk and Intercom. As a result, Actionstep’s Support and Accounting teams were unable to send or receive tickets, live chats, or email communications during the disruption.

Impact
The issue occurred between approximately 9:38 a.m. and 10:04 a.m. MDT. During this time, customers were unable to contact Actionstep Support or Accounting through normal channels. The outage originated from AWS infrastructure supporting Freshdesk and Intercom and did not involve any Actionstep systems.

Resolution
Freshdesk restored services once AWS resolved the underlying issue. Actionstep teams verified full functionality and resumed normal support operations immediately after recovery.

Next Steps
We are reviewing backup communication options and evaluating redundancy for critical customer communication tools to ensure we can continue providing updates and assistance during future third-party outages.

Acknowledgement
We understand the inconvenience this caused and apologize for the disruption to your ability to reach our teams. Maintaining reliable communication and support availability is a top priority, and we are taking steps to strengthen our resilience against external service interruptions.

Posted Oct 21, 2025 - 09:29 NZDT

Resolved

Final Update – Support System Outage

Our support system (Freshdesk) has now been fully restored following the earlier AWS outage.

However, our Practice Management Platform—which is hosted on the AWS US-East region—remains impacted due to ongoing AWS service disruption in that region. Customer databases in this region are still unavailable.

A separate incident has been created to track the Practice Management platform outage specifically. This post will now be closed to reflect that the original support system disruption has been resolved.

We appreciate your continued patience as we monitor AWS’s progress and work to restore full access as soon as possible.
Posted Oct 21, 2025 - 05:04 NZDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 04:42 NZDT

Monitoring

We are currently investigating an issue related to a widespread AWS outage affecting multiple services globally.

Our Practice Management Platform is affected for customers on the US-East-1 Serverl; other regions are functioning.

Our support ticketing system (Freshdesk) is also impacted. This may delay responses to support requests.

Our Legal Accounting Platform is also fully operational, but its Intercom chat support is currently unavailable due to the same AWS outage.

We are monitoring the situation closely and will restore normal support operations as soon as AWS resolves the issue.

Further updates will be posted here as they become available.
Posted Oct 21, 2025 - 04:38 NZDT
This incident affected: Canada, USA (West), USA (East), United Kingdom, Middle East, Africa, and Europe, and New Zealand, Australia, and South Pacific.