UK - Server Outage (eu-west-1) - 22/04/2025

Incident Report for Actionstep

Postmortem

Post-Incident Review: Invoice Payments List Performance Degradation

Date of Incident: Tuesday, April 22, 2025

What Happened?

During our routine software release on Tuesday, an update to the invoice payments list introduced performance degradation, causing slower query execution. This, combined with a high volume of users accessing the invoice payments list (which also functions as a report), led to server overload and timeouts.

The root cause was a surge in long-running queries. While individually these queries might have been manageable under normal load, the increased latency from the update triggered numerous user retries. This resulted in the simultaneous execution of many resource-intensive queries, creating a significant backlog and further compounding the performance issues into a negative feedback loop of retries and slowdowns.

What We Did:

To address the immediate impact and restore service stability, we took the following actions:

  • Resource Scaling: We doubled the available resources on the affected server, allowing the backlog to clear and restoring normal performance.
  • Release Rollback: We rolled back the Tuesday release to the previous stable version, immediately removing the problematic code changes.

What We Are Doing to Prevent Recurrence:

To prevent similar incidents in the future, we are taking the following steps:

  • Server Capacity Management: We are adding more servers and will migrate users to distribute load and improve overall performance.
  • Query Optimization: We are thoroughly investigating and tuning the slow-running queries powering the invoice payments list to improve efficiency.
Posted 1 month ago. Apr 23, 2025 - 21:18 NZST

Resolved

We are communicating to provide further information on the outage that affected the Actionstep platform on 22/04/2025 and confirm that the issue is now resolved.

This outage started at 10 AM (GMT) and prevented user access to the system—some customers who managed to log in experienced error messages and periods of instability and slowness.

It is important to confirm that no data was lost and that the issue is only related to platform performance.

Our team investigated the issue as the sole priority and released an urgent fix at 12:25 PM. This fix restored platform access and brought system performance back to normal levels.

The Actionstep team appreciates the impact this outage may have had on your business and reiterates our commitment to improving the experience of all customers who use the platform.

We have identified the root cause of the issue and implemented steps to prevent it from occurring again.

Regards,
Actionstep Support Team
Posted 1 month ago. Apr 22, 2025 - 23:28 NZST

Monitoring

We wanted to provide an update on the outage affecting the Actionstep system, which was communicated earlier.

Our team have identified the root cause of the problem and are preparing a fix to be released that will return the system to normal operations.

We will provide more information once we have a release time and further information as required.

Regards,
Actionstep Support Team
Posted 1 month ago. Apr 22, 2025 - 23:22 NZST

Update

We are continuing to investigate this issue.

We thank you for your patience and apologise for the inconvenience.
Posted 1 month ago. Apr 22, 2025 - 23:11 NZST

Update

We are continuing to investigate this issue.
Posted 1 month ago. Apr 22, 2025 - 22:01 NZST

Investigating

Our team are aware of a performance issue that is resulting in slowness and delays when using particular aspects of the Actionstep system.

Specifically, these performance issues are affecting on eu-west-1.actionstep.com.

Our team is investigating this as a priority and will work to restore the system to normal operations urgently.

We will communicate with you regularly regarding the progress of this work to ensure you are back online as soon as possible.

In the meantime, our support team is available by https://support.actionstep.com if you require assistance.


Regards,
Actionstep Support Team
Posted 1 month ago. Apr 22, 2025 - 21:38 NZST
This incident affected: United Kingdom, Middle East, Africa, and Europe.