Issue Identified - EU-WEST 05/08/2025

Incident Report for Actionstep

Postmortem

We recently experienced a service interruption on our eu-west-1 server on the 5th of August 2025 that caused degraded performance for some customers. The issue was related to unusually high levels of API activity on one of our servers, which impacted system stability.

We isolated the source of the high traffic and moved it to a separate environment to restore performance. We are also reviewing our current rate-limiting and monitoring systems to help prevent similar issues in the future.

We apologise for any inconvenience this caused and thank you for your understanding as we continue to improve the reliability of our service.

Posted Aug 15, 2025 - 04:35 NZST

Resolved

We are providing additional information regarding the performance issues that affected the Actionstep Practice Management platform on 05/08/2025 and confirming that the issue has now been resolved.

These performance issues occurred from 3:15 PM to 5:20 PM, and customers using the system during this time experienced periods of instability and slowness.

We can confirm that no data was lost and that the issue was solely related to platform performance.

The Actionstep team appreciates the impact this issue may have had on your business, and we want to reaffirm our commitment to enhancing the experience for all customers who use our platform.

We have identified the root cause of the problem and taken steps to prevent it from happening again in the future.

Regards,
Actionstep Support Team
Posted Aug 06, 2025 - 03:21 NZST

Monitoring

We wanted to provide an update on the performance and slowness issues communicated earlier.

Our team has released a fix, and we are seeing performance return to normal. We will continue to monitor the situation and keep everyone updated.

Regards,
Actionstep Support Team
Posted Aug 06, 2025 - 03:14 NZST

Update

We wanted to provide an update on the performance and slowness issue communicated earlier.

Our team has identified the root cause of the problem and is preparing a fix to be released that will restore the system to normal operation. We will provide more information once we have a release date and any additional updates as needed.

Regards,
Actionstep Support Team
Posted Aug 06, 2025 - 03:08 NZST

Update

We would like to give an update on the issue we previously reported.

Our team is still working to resolve the issue, which remains our top priority. We appreciate your patience and encourage you to contact us by submitting a ticket at https://support.actionstep.com if you need further assistance.

We will keep you updated on our progress to ensure you are back online as soon as possible.

Regards,
Actionstep Support Team
Posted Aug 06, 2025 - 02:53 NZST

Identified

Our team has identified an issue with the Actionstep Practice Management Platform, specifically with performance problems and overall slowness across the platform.

Our team is investigating this as a priority and will work to restore the system to normal operations urgently.

We will communicate with you regularly regarding the progress of this work to ensure you are back online as soon as possible.

In the meantime, our support team is available by reach out to us by way of ticket submission at https://support.actionstep.com if you require assistance.

Regards,
Actionstep Support Team
Posted Aug 06, 2025 - 02:15 NZST
This incident affected: United Kingdom, Middle East, Africa, and Europe.