"500 internal server" error when we open up matters.

Incident Report for Actionstep

Resolved

This incident has been resolved.
Posted Nov 18, 2022 - 05:15 NZDT

Investigating

We are currently investigating this issue.
Posted Nov 18, 2022 - 03:52 NZDT
This incident affected: USA (East).