Matter/Folder Duplication upon creation - all regions

Incident Report for Actionstep

Postmortem

Post-Incident Summary – Folder Duplication Issue (June 24, 2025)

Status: Resolved

Summary:
On June 24, 2025, an issue occurred where folders were duplicated when creating a matter in the Actionstep Practice Management platform. This was caused by a routine release, which was quickly rolled back.

Impact:

  • Duplicate folders were created when adding new matters.
  • Affected folders will need to be manually deleted by users.

Resolution:
The issue was identified and resolved promptly. The release responsible was rolled back.

Next Steps:
We have identified the root cause and implemented safeguards to prevent this from occurring in future releases.

We sincerely apologize for the inconvenience and appreciate your understanding.

Posted Jul 01, 2025 - 03:35 NZST

Resolved

We are reaching out to provide additional information regarding the folder duplication issue that occurred while creating a matter on the Actionstep Practice Management platform on June 24, 2025. We are pleased to confirm that this issue has now been resolved.

Please be aware that any duplicate folders created will need to be deleted manually.

The issue arose due to a routine release that was subsequently rolled back.

The Actionstep team understands the impact this issue may have had on your business, and we want to reaffirm our commitment to enhancing the overall experience for all customers using the platform.

We have identified the root cause of the problem and have taken steps to prevent it from happening in future releases.

Regards,
Actionstep Support Team
Posted Jun 24, 2025 - 15:41 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 15:32 NZST

Update

We are continuing to work on a fix for this issue.
Posted Jun 24, 2025 - 15:30 NZST

Identified

Our team has identified an issue when creating new matters that is resulting in duplications in both matters and folders.

Our team is investigating this as a priority and will work to restore the system to normal operations urgently.

We will communicate with you regularly regarding the progress of this work to ensure you are back online as soon as possible.

In the meantime, our support team is available by reach out to us by way of ticket submission at https://support.actionstep.com if you require assistance.

Regards,
Actionstep Support Team
Posted Jun 24, 2025 - 12:30 NZST
This incident affected: Canada, USA (West), USA (East), United Kingdom, Middle East, Africa, and Europe, New Zealand, Australia, and South Pacific, and Asia.