UK - Server Outage (eu-west-1)

Incident Report for Actionstep

Postmortem

Post-Incident Review: Integration Issue Impacting Server Performance

Date of Incident: Thursday, April 24, 2025

What Happened?

On Thursday, an issue with one of our integrations caused it to become overloaded. This initial overload led to a slowdown in our server's ability to process requests efficiently. As the server became slower, other functions also started to experience delays and timeouts. This created a situation where the system became increasingly unresponsive, impacting overall performance and the speed at which tasks could be completed.

What We Did:

To address the immediate impact and restore service stability, we took the following action:

Resource Scaling: We increased the capacity of the affected server. This allowed the server to manage the backlog of requests and return to normal performance levels.

What We Are Doing to Prevent Recurrence:

To prevent similar incidents in the future, we are taking the following steps:

Server Capacity Management: We are actively working on increasing the number of servers we have available. This will help us to better distribute the workload and improve overall performance, preventing slowdowns even during periods of high demand or unexpected issues. This work is currently underway.

Integration Review: We are carefully reviewing the integration that experienced the issue. Our goal is to understand exactly what happened and to put measures in place to prevent similar problems from occurring again.

Posted Apr 25, 2025 - 23:25 NZST

Resolved

We are communicating to provide further information on the outage that affected the Actionstep platform on 24/04/2025 and confirm that the issue is now resolved.

This outage started at 1:40 PM and prevented user access to the system—some customers who managed to log in experienced error messages and periods of instability and slowness.

It is important to confirm that no data was lost, and the issue only concerns platform performance.

Our team investigated the issue as the sole priority and released an urgent fix at 3:10 PM, restoring platform access and bringing system performance back to normal.

The Actionstep team appreciates this outage's impact on your business, and we want to reiterate our commitment to improving the experience of all customers who use the platform.

We have identified the root cause of the issue and implemented steps to prevent it from occurring again.

Regards,
Actionstep Support Team
Posted Apr 25, 2025 - 02:38 NZST

Monitoring

We wanted to provide an update on the outage affecting the Actionstep platform, which was communicated earlier.

Our team has identified the root cause of the problem and is preparing a fix to be released that will return the system to normal operations. We will provide more information once we have a release time and further information as required.

Regards,
Actionstep Support Team
Posted Apr 25, 2025 - 01:47 NZST

Investigating

Our team have identified an issue with Actionstep that is resulting in system crashing out.
Specifically, these performance issues are affecting the system in UK - Server Outage (eu-west-1) RDS 100003

Our team is investigating this as a priority and will work to restore the system to normal operations urgently.

We will communicate with you regularly regarding the progress of this work to ensure you are back online as soon as possible.

In the meantime, our support team is available by reach out to us by way of ticket submission at https://support.actionstep.com if you require assistance.


Regards,
Actionstep Support Team
Posted Apr 25, 2025 - 00:50 NZST
This incident affected: United Kingdom, Middle East, Africa, and Europe.