Issue Resolved - server outage 27/03/2025

Incident Report for Actionstep

Resolved

We are communicating to provide information on the outage that affected Actionstep Customers on 27/03/2025 and confirm that the issue is now resolved.

This outage started at 8:51 AM (AEST) and prevented user access to the system. Some customers who managed to log in experienced error messages

It is important to confirm that no data was lost and the issue was related to platform performance only.

Our team investigated the issue as its sole priority and, once reported, released an urgent fix at 9:09 AM (AEST). This fix restored platform access and brought system performance back to normal levels.

The Actionstep team appreciates this outage's impact on your business and reiterates our commitment to improving the experience of all customers who use the platform.

We have identified the root cause of the issue and implemented steps to prevent it from occurring again.

Regards,
Actionstep Support Team
Posted Mar 27, 2025 - 11:51 NZDT