South-East Servers slowness
Incident Report for Actionstep
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 12:09 NZDT
Investigating
We are currently investigating this issue.
Posted Nov 22, 2022 - 11:53 NZDT
This incident affected: New Zealand, Australia, and South Pacific and Auckland Office.