Server Outage - ap-southeast-2

Incident Report for Actionstep

Postmortem

What Happened

On June 18, 2025, our platform experienced a performance issue during a period of high traffic. Some customers may have experienced slow performance or temporary outages.

The issue was caused by a failure in an automated process we use to prepare our servers for peak demand. This failure was linked to an outage at GitHub, a third-party service we use to manage parts of our deployment process. As a result, our servers did not scale up as they normally would during busy periods, leading to the disruption.

What We Did

Our engineering team was alerted shortly after the issue began. Once the cause was identified, we manually deployed the necessary updates to restore normal service levels. Full functionality was restored quickly after this intervention.

How We’re Preventing This in Future

  • We are improving our monitoring so failures like this trigger immediate alerts before they can impact customers.
  • We are updating our deployment processes to remove reliance on this type of step, which will prevent similar issues in the future.
  • Our teams are conducting a full review to identify and address any additional improvements needed.

We’re Sorry for the Disruption

We know how critical our platform is to your daily operations, and we sincerely apologize for this disruption. We are committed to learning from this and continuing to improve the reliability of our services.

If you have any questions, please don’t hesitate to reach out to our support team.

Posted Jun 27, 2025 - 03:01 NZST

Resolved

We are writing to provide additional information regarding the outage that affected the Actionstep Practice Management platform on June 19, 2025 (NZ). We are pleased to confirm that the issue has now been resolved.

The outage began at 10 AM NZST and temporarily prevented users from accessing the system.

We want to assure you that no data was lost; the issue was solely related to access to the platform.

Our team prioritized this issue and released an urgent fix at 10:40 AM, which restored platform access and returned system performance to normal levels.

The Actionstep team understands the impact this outage may have had on your business, and we want to reaffirm our commitment to enhancing the experience for all customers who use the platform.

A post-mortem update will be published in the coming week with further details.

Regards,
Actionstep Support Team
Posted Jun 19, 2025 - 10:47 NZST

Monitoring

We would like to provide an update on the outage affecting the Actionstep Practice Management system that we communicated earlier.

Our team has identified the root cause of the problem and has released a fix. We are observing improvements in the system and will continue to monitor its performance while providing further updates.

Regards,
Actionstep Support Team
Posted Jun 19, 2025 - 10:39 NZST

Update

We are continuing to work on a fix for this issue.
Posted Jun 19, 2025 - 10:33 NZST

Update

We are continuing to work on a fix for this issue.
Posted Jun 19, 2025 - 10:21 NZST

Identified

We wanted to provide an update on the outage affecting the Actionstep Practice Management system, which was communicated earlier.

Our team has identified the root cause of the problem and is preparing a fix to be released that will return the system to normal operations. We will provide more information once we have a release time and further information as required.

Regards,
Actionstep Support Team
Posted Jun 19, 2025 - 10:11 NZST

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 10:10 NZST

Investigating

We are writing to inform that our team is aware of an outage affecting the Actionstep Practice Management system that began on 19/06/2025 at 10AM NZ time.

Our team is investigating this as the top priority and will work to restore the system to full functionality urgently.

We will communicate with you regularly regarding the progress of this work to ensure you are back online as soon as possible.

In the meantime, our support team is available by way of ticket submission to https://support.actionstep.com if you require assistance.

Regards,
Actionstep Support Team
Posted Jun 19, 2025 - 10:08 NZST
This incident affected: New Zealand, Australia, and South Pacific.