US East Coast Slowness due to Amazon Web Services

Incident Report for Actionstep

Resolved

This incident has now been resolved by Amazon and normal service has resumed. Thank you for your patience and we apologize for any inconvenience caused.
Posted Nov 26, 2020 - 04:54 NZDT

Investigating

There is currently an issue with Amazon Web Services that is affecting the US East Coast Actionstep system, this is being investigated by Amazon and we will keep you updated once we have more information.
Posted Nov 26, 2020 - 04:36 NZDT
This incident affected: USA (East).